PHP is amongst the most widely used open-source server-side scripting languages. It is very popular as it’s free software, which can be used to create responsive sites such as social networks, shopping portals or e-learning portals as opposed to static HTML sites. A PHP module must be available on the server where a PHP-powered website is hosted so that its source code can be ‘deciphered’. Since there are no license fees for such a module and the language itself provides incalculable possibilities for the web apps that you develop, there’re hundreds of millions of PHP-driven sites. Additionally, there’re lots of open-source PHP-based scripts, which you can use for your websites without the need to have any coding knowledge. As there’re a number of PHP versions, you must verify whether the same version that you used while setting up your website is present on the server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Web Hosting

If you purchase a cloud web hosting package from our company, you will never have to ponder whether or not your websites are compatible with the hosting platform, as multiple PHP versions are available on our servers for your convenience’s sake. The Hepsia hosting Control Panel will allow you to pick PHP 4, PHP 5 and PHP 7 with just one click of the mouse and if you want to change the version, the new settings will take effect right away. Thus, several years of work on websites built with an older version of PHP will not go down the drain. Our web hosting platform will even permit you to use a different PHP version for each domain name hosted in your account, so you can run older and newer scripts at the same time. Most hosting providers on the market offer one, sometimes two PHP versions. In contrast to them, we strongly trust that you should be the one to choose the version that your very own sites will use.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

In case you have a site built with a previous version of PHP and you have donated time and energy to developing it, plugging safety breaches and posting content, you’ll need a web hosting service that can support it, as nearly all hosting providers these days offer support only for the most recently published PHP version and remove the older ones. We, however, have decided to allow you to select the version that your own sites need. Our semi-dedicated servers support PHP 4, PHP 5 and PHP 7, which implies that you will be able to use both older and newer scripts without losing any custom modifications or frittering away time and effort attempting to make your sites compatible with the web hosting platform. You can change the current version from the Hepsia hosting Control Panel and such an update will affect the entire semi-dedicated account, but you’ll also be able to pick a different version of PHP for each website that you host in your account by means of an .htaccess file.